简介

教务管理系统说明

    随着信息技术的发展，各类教育软件是学校教学、教务的十分重要和出色的帮手，它快速、切实的工作方式，使教学管理者从繁琐的教务工作中解脱出来，提高了工作效率。本系统的设计是建立在北京一零一中多年教学管理实践的基础上，针对中小学教学、教务的特点开发出中小学教务管理系统。

    本系统利用 C/S 模式及 B/S 模式，集学籍管理、成绩管理及排课于一体，操作使用方便，输出内容丰富，是教务工作及学生学习情况分析的好助手。

    程序的主要特色：

    ☆　方便的输入输出功能，可在电子表格、文本文件、剪贴板之间方便交流数据
    ☆　程序做到一次输入与统计，便可输出各种报表及图表
    ☆　完善的跟踪功能，可查询任一名学生历次考试记录
    ☆　考试分析功能丰富，有标准分，成绩分析更具客观性
    ☆　教师、学生都可在自己的权限范围内查询成绩
    ☆　可以通过互联网在家录入、查询成绩
    ☆　具有数据锁定功能，保证数据的安全与真实性
    ☆　具有学籍管理功能，方便教务的学籍管理工作
    ☆　具有方便的数据备份/恢复功能，不用担心数据的丢失


服务器安装

服务器最好安装 Windows 2000 系统（包含 IIS 服务组件）及最新的系统补丁。
下面介绍安装 Microsoft SQL Server 2000 Standard Edition 的步骤：
运行 setup.exe；

选择“安装 SQL Server 2000 组件”；

选择“下一步”；

选择“本地计算机”；

选择“创建新的 SQL Server 实例，或安装‘客户端工具’”；

输入“姓名”和“公司”；

选择“是”；

选择“服务器和客户端工具”；

选择“默认”；

选择“典型”，配置“程序文件”和“数据文件”的“目的文件夹”；

选择“对每个服务使用同一帐户。自动启动 SQL Server 服务。”；

选择“混合模式”，输入密码信息，注意尽量输入复杂一些的密码；

选择“下一步”；

选择“每客户”，输入“设备”数；

选择“完成”即完成服务器程序的安装。


服务配置

运行“企业管理器”

选择“控制台根目录”下的“数据库”，在窗口右下方空白处单击鼠标右键，选择“新建数据库…”；

输入数据库名称 SMS；

选择“控制台根目录”下的“用户”，在窗口右下方空白处单击鼠标右键，选择“新建数据库用户…”；

选择“<新建>”；

在“常规”页输入“名称”（例如 ceshizhanghao），身份验证选择“SQL Server 身份验证”，输入“密码”（例如 i9y5j7KeH8Z4a2），“数据库”选择“SMS”；

在“服务器角色”页里设置服务器角色为“System Administrator”；

在“数据库访问”页里“指定此登录可以访问的数据库”选择“SMS”；

再次输入“确认密码”，服务器端配置完毕。


客户端安装

客户端可安装在 Windows98 以上操作系统。运行安装文件 setup.exe，

点击“下一步”按钮；

选择“我接受该许可证协议中的条款”，点击“下一步”按钮；

输入“用户姓名”及“单位”，选择“此应用程序的使用者”，点击“下一步”按钮；

配置“目的地文件夹”，点击“下一步”按钮；

点击“安装”按钮；

等待程序的安装……

点击“完成”按钮完成安装，安装程序在桌面及系统菜单生成快捷方式图标 [image] ，安装完毕。

运行成绩管理系统


管理员使用说明

运行“成绩管理系统”，出现登录对话框：

默认的管理员帐号为“管理员”，密码为空，点击“登录”按钮，然后重新设定密码；

选择菜单“资源管理”下的“在编年级”：

输入班级信息，“序号”仅作为排序之用，点击“更新”按钮；

选择菜单“资源管理”下的“教师设置”：

输入教师信息，其中密码“d41d8cd98f00b204e9800998ecf8427e”代表空密码；按 Ctrl-D 可删除游标所在记录；

管理员具有一切权限；
教务处不具备“资源管理”功能；
校领导可查询任何成绩；
年级组只可查询该年级成绩，可新建、录入全年级各科成绩；
班主任只可查询该年级成绩，可录入该班级各科成绩；
教研组可查询该科历次考试成绩分析；
备课组可查询该年级该科历次考试成绩分析；
查成绩只可查询成绩；

选择菜单“资源管理”下的“学籍管理”：

检索号是每个学生的标识号，不可缺少，系统根据此检索号跟踪学生的数据。检索号共 10 位，请按此规则设定：前四位为毕业年份（届别），如2007；中间两位：小学为 00，初中为 01，高中为 02；后四位为流水号。如：2006020001。

输入学生信息（至少输入检索号、姓名、班级、学号、届别、级别、年级、文理），学生信息可从剪贴板导入（导入关键字要放在记录的最前面），如果系统内无此检索号，则此记录作为新记录导入，如果系统内已存在此检索号，则用新字段内容替换旧字段内容；

以上设置是本系统能正常运行的前提条件。

管理员的其它权限可在“资源管理”下找到并运行。

其中“发布通知”是指在状态栏显示的文字信息。


一般用户使用说明

1、新建考试：选择菜单“成绩处理”下的“新建考试”下的“新建”：

其中“类型”可根据情况修改。

2、数据录入：选择菜单“成绩处理”下的“数据录入”：

3、成绩统计：选择菜单“成绩处理”下的“成绩统计”：

4、整体查询：选择菜单“成绩查询”下的“整体查询”：

5、个人查询：选择菜单“成绩查询”下的“个人查询”：

6、常用表格：